$re = '/^-?(0|1000|[1-9]\d{0,2})(?:\.\d{1,2})?$/m';
$str = '001
01
-0
0
-1
1
10
-10
-1000
-999.99
0001
1000
1001
10000
-1000
0.001
0.01
0.1
0032
1.2
0.2
-0.2
123
100
199
233
459
999
888
-999
-888
-123.21
-021.32
9999
-1.010
01.32
99.99
0
-1.2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);