import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^-?(0|1000|[1-9]\\d{0,2})(?:\\.\\d{1,2})?$";
final String string = "001\n"
+ "01\n"
+ "-0\n"
+ "0\n"
+ "-1\n"
+ "1\n"
+ "10\n"
+ "-10\n"
+ "-1000\n"
+ "-999.99\n"
+ "0001\n"
+ "1000\n"
+ "1001\n"
+ "10000\n"
+ "-1000\n"
+ "0.001\n"
+ "0.01\n"
+ "0.1\n"
+ "0032\n"
+ "1.2\n"
+ "0.2\n"
+ "-0.2\n"
+ "123\n"
+ "100\n"
+ "199\n"
+ "233\n"
+ "459\n"
+ "999\n"
+ "888\n"
+ "-999\n"
+ "-888\n"
+ "-123.21\n"
+ "-021.32\n"
+ "9999\n"
+ "-1.010\n"
+ "01.32\n"
+ "99.99\n"
+ "0\n"
+ "-1.2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}