# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^-?(0|1000|[1-9]\d{0,2})(?:\.\d{1,2})?$"
test_str = ("001\n"
"01\n"
"-0\n"
"0\n"
"-1\n"
"1\n"
"10\n"
"-10\n"
"-1000\n"
"-999.99\n"
"0001\n"
"1000\n"
"1001\n"
"10000\n"
"-1000\n"
"0.001\n"
"0.01\n"
"0.1\n"
"0032\n"
"1.2\n"
"0.2\n"
"-0.2\n"
"123\n"
"100\n"
"199\n"
"233\n"
"459\n"
"999\n"
"888\n"
"-999\n"
"-888\n"
"-123.21\n"
"-021.32\n"
"9999\n"
"-1.010\n"
"01.32\n"
"99.99\n"
"0\n"
"-1.2")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.