use strict;
my $str = '001
01
-0
0
-1
1
10
-10
-1000
-999.99
0001
1000
1001
10000
-1000
0.001
0.01
0.1
0032
1.2
0.2
-0.2
123
100
199
233
459
999
888
-999
-888
-123.21
-021.32
9999
-1.010
01.32
99.99
0
-1.2';
my $regex = qr/^-?(0|1000|[1-9]\d{0,2})(?:\.\d{1,2})?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}