using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?!red|green|blue).)*$";
string input = @"this is a red dragon
this is an orange dragon
this is a yellow dragon
this is a green dragon
this is a blue dragon
this is a purple dragon";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}