import re
regex = re.compile(r"^(?:(?!red|green|blue).)*$", flags=re.MULTILINE)
test_str = ("this is a red dragon\n\n"
"this is an orange dragon\n\n"
"this is a yellow dragon\n\n"
"this is a green dragon\n\n"
"this is a blue dragon\n\n"
"this is a purple dragon")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")