import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?!red|green|blue).)*$";
final String string = "this is a red dragon\n\n"
+ "this is an orange dragon\n\n"
+ "this is a yellow dragon\n\n"
+ "this is a green dragon\n\n"
+ "this is a blue dragon\n\n"
+ "this is a purple dragon";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}