$re = '/^(?:(?!red|green|blue).)*$/m';
$str = 'this is a red dragon
this is an orange dragon
this is a yellow dragon
this is a green dragon
this is a blue dragon
this is a purple dragon';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);