re = /^(?:(?!red|green|blue).)*$/m
str = 'this is a red dragon
this is an orange dragon
this is a yellow dragon
this is a green dragon
this is a blue dragon
this is a purple dragon'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end