# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?|(\d{3})([A-Z]{2})(\d)|(\d{2})(\d{2})([A-Z]{2}))$/$1-$2-$3/gm;t' <<< "999TB2
9999XX"