use strict;
my $str = '999TB2
9999XX';
my $regex = qr/^(?|(\d{3})([A-Z]{2})(\d)|(\d{2})(\d{2})([A-Z]{2}))$/mp;
my $subst = '$1-$2-$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";