import Foundation
let pattern = #"^(?|(\d{3})([A-Z]{2})(\d)|(\d{2})(\d{2})([A-Z]{2}))$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
999TB2
9999XX
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1-$2-$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)