package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?|(\d{3})([A-Z]{2})(\d)|(\d{2})(\d{2})([A-Z]{2}))$`)
var str = `999TB2
9999XX`
var substitution = "$1-$2-$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}