$re = '/^(?|(\d{3})([A-Z]{2})(\d)|(\d{2})(\d{2})([A-Z]{2}))$/m';
$str = '999TB2
9999XX';
$subst = "$1-$2-$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;