#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[DM][rR][sS]?|M[Ss])\. .+"
Local $sString = "Mr. " & @CRLF & _
"Mr. D" & @CRLF & _
"MR. D" & @CRLF & _
"MRS. D" & @CRLF & _
"Mrs. D" & @CRLF & _
"MS. D" & @CRLF & _
"Ms. D" & @CRLF & _
"DR. D" & @CRLF & _
"Dr. D" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")