re = /^(?:[DM][rR][sS]?|M[Ss])\. .+/m
str = 'Mr.
Mr. D
MR. D
MRS. D
Mrs. D
MS. D
Ms. D
DR. D
Dr. D
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end