import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[DM][rR][sS]?|M[Ss])\\. .+";
final String string = "Mr. \n"
+ "Mr. D\n"
+ "MR. D\n"
+ "MRS. D\n"
+ "Mrs. D\n"
+ "MS. D\n"
+ "Ms. D\n"
+ "DR. D\n"
+ "Dr. D\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}