$re = '/^(?:[DM][rR][sS]?|M[Ss])\. .+/m';
$str = 'Mr.
Mr. D
MR. D
MRS. D
Mrs. D
MS. D
Ms. D
DR. D
Dr. D
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);