using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[DM][rR][sS]?|M[Ss])\. .+";
string input = @"Mr.
Mr. D
MR. D
MRS. D
Mrs. D
MS. D
Ms. D
DR. D
Dr. D
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}