using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"d(?:uration)?:(?<time>.*?)\s*t(?:itle)?:(?<title>.*?)\s*(?:p(?:rize)?:(?<prize>.*))?$";
string input = @"duration:1h 5m 1s title:Title test prize: here
duration:1h 5m 1s title:Title test";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}