$re = '/d(?:uration)?:(?<time>.*?)\s*t(?:itle)?:(?<title>.*?)\s*(?:p(?:rize)?:(?<prize>.*))?$/m';
$str = 'duration:1h 5m 1s title:Title test prize: here
duration:1h 5m 1s title:Title test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);