import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "d(?:uration)?:(?<time>.*?)\\s*t(?:itle)?:(?<title>.*?)\\s*(?:p(?:rize)?:(?<prize>.*))?$";
final String string = "duration:1h 5m 1s title:Title test prize: here\n"
+ "duration:1h 5m 1s title:Title test";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}