re = /d(?:uration)?:(?<time>.*?)\s*t(?:itle)?:(?<title>.*?)\s*(?:p(?:rize)?:(?<prize>.*))?$/m
str = 'duration:1h 5m 1s title:Title test prize: here
duration:1h 5m 1s title:Title test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end