package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)d(?:uration)?:(?<time>.*?)\s*t(?:itle)?:(?<title>.*?)\s*(?:p(?:rize)?:(?<prize>.*))?$`)
var str = `duration:1h 5m 1s title:Title test prize: here
duration:1h 5m 1s title:Title test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}