package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.(.*)[^.]`)
var str = `{"rates":{"BRL":6.7607,"USD":1.1698},"base":"EUR","date":"2020-10-30"}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}