// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.(.*)[^.]").unwrap();
let string = "{\"rates\":{\"BRL\":6.7607,\"USD\":1.1698},\"base\":\"EUR\",\"date\":\"2020-10-30\"}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}