$re = '/^.(.*)[^.]/m';
$str = '{"rates":{"BRL":6.7607,"USD":1.1698},"base":"EUR","date":"2020-10-30"}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);