re = /^.(.*)[^.]/m
str = '{"rates":{"BRL":6.7607,"USD":1.1698},"base":"EUR","date":"2020-10-30"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end