#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^(\d*\.?\d+)(.*)"
Local $sString = "0.5An55.5Tik"
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)