const regex = /^(\d*\.?\d+)(.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d*\\.?\\d+)(.*)', 'g')
const str = `0.5An55.5Tik`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);