$re = '/^(\d*\.?\d+)(.*)/';
$str = '0.5An55.5Tik';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;