import Foundation
let pattern = #"^(\d*\.?\d+)(.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"0.5An55.5Tik"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)