using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d*\.?\d+)(.*)";
string substitution = @"\n";
string input = @"0.5An55.5Tik";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}