const regex = /^(?<line>.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<line>.*)$', 'gm')
const str = `GDS/Cordicate Admin follow-up required
Local Computer Files - Archive the offboarding users business folder
RPOP Office 365 (remove active licensing and add ons)
Zee Drive licensing deletion
Azure Active Directory deletion (Kardin)
MRI Account deletion
Avid XChange Account deletion
Distribution group lists removal - Everyone and RPOP
Global Address listing removal
Business phone extension license removal
Engineering Share deletion (if used)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}