# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<line>.*)$"
test_str = ("GDS/Cordicate Admin follow-up required\n"
"Local Computer Files - Archive the offboarding users business folder\n"
"RPOP Office 365 (remove active licensing and add ons)\n"
"Zee Drive licensing deletion\n"
"Azure Active Directory deletion (Kardin)\n"
"MRI Account deletion\n"
"Avid XChange Account deletion\n"
"Distribution group lists removal - Everyone and RPOP\n"
"Global Address listing removal\n"
"Business phone extension license removal\n"
"Engineering Share deletion (if used)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.