package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`call is (?<callTime>\d+)`)
var str = `Total time taken for call is 1554
Total time taken for call is 2349685
Total time taken for call is 189`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}