// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"call is (?<callTime>\d+)").unwrap();
let string = "Total time taken for call is 1554
Total time taken for call is 2349685
Total time taken for call is 189";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}