$re = '/call is (?<callTime>\d+)/';
$str = 'Total time taken for call is 1554
Total time taken for call is 2349685
Total time taken for call is 189';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);