re = /call is (?<callTime>\d+)/
str = 'Total time taken for call is 1554
Total time taken for call is 2349685
Total time taken for call is 189'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end