using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\$)(.*?)[\*\_]{2}([^\*\_]+)[\*\_]{2}(.*?)(?:\$)";
string input = @"$ asd **deneme** asd $ sdfasda **bold** $ dasd **bold** sdd $
**deneme**
(?:Jane|John|Alison)\s(.*?)\s(?:Smith|Smuth)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}