re = /(?:\$)(.*?)[\*\_]{2}([^\*\_]+)[\*\_]{2}(.*?)(?:\$)/m
str = '$ asd **deneme** asd $ sdfasda **bold** $ dasd **bold** sdd $
**deneme**
(?:Jane|John|Alison)\\s(.*?)\\s(?:Smith|Smuth)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end