package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\$)(.*?)[\*\_]{2}([^\*\_]+)[\*\_]{2}(.*?)(?:\$)`)
var str = `$ asd **deneme** asd $ sdfasda **bold** $ dasd **bold** sdd $
**deneme**
(?:Jane|John|Alison)\s(.*?)\s(?:Smith|Smuth)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}