import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\$)(.*?)[\\*\\_]{2}([^\\*\\_]+)[\\*\\_]{2}(.*?)(?:\\$)";
final String string = "$ asd **deneme** asd $ sdfasda **bold** $ dasd **bold** sdd $\n"
+ "**deneme**\n\n"
+ "(?:Jane|John|Alison)\\s(.*?)\\s(?:Smith|Smuth)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}