// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\$)(.*?)[\*\_]{2}([^\*\_]+)[\*\_]{2}(.*?)(?:\$)").unwrap();
let string = "$ asd **deneme** asd $ sdfasda **bold** $ dasd **bold** sdd $
**deneme**
(?:Jane|John|Alison)\\s(.*?)\\s(?:Smith|Smuth)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}