package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*\/0([^.]|$|\.(0{4,}.*|0{1,4}([^0-9]|$))).*`)
var str = `1/0
1/0.00+1
1/0.00001+1
1/0.0001+1
1/0.1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}