re = /.*\/0([^.]|$|\.(0{4,}.*|0{1,4}([^0-9]|$))).*/
str = '1/0
1/0.00+1
1/0.00001+1
1/0.0001+1
1/0.1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end