// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*\/0([^.]|$|\.(0{4,}.*|0{1,4}([^0-9]|$))).*").unwrap();
let string = "1/0
1/0.00+1
1/0.00001+1
1/0.0001+1
1/0.1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}