import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*\\/0([^.]|$|\\.(0{4,}.*|0{1,4}([^0-9]|$))).*";
final String string = "1/0\n\n"
+ "1/0.00+1\n"
+ "1/0.00001+1\n"
+ "1/0.0001+1\n"
+ "1/0.1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}