#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)EMAIL:\s*([a-zA-Z0-9_.±]+@[a-zA-Z0-9-]+.[a-zA-Z0-9-.]+)\s*Τηλέφωνο:\s*(?<phone>\+?[\d\s-]+?)\s*Είστε πιστοποιημένος θεραπευτής;(?<therapist>[^\n]+)\s*Συμμετέχετε σε θεραπευτική εκπαίδευση;:(?<psychotherapy>[^\n]+)\s*"
Local $sString = "Contact form - therapistForm " & @CRLF & _
" Below are the values the user has filled in the form. Beware they are not verified in any way and anyone could have sent the form as it is public. " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"EMAIL: katerina@hedepy.gr" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"Τηλέφωνο: 123456789" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"Είστε πιστοποιημένος θεραπευτής;: ναι" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"Συμμετέχετε σε θεραπευτική εκπαίδευση;: ναι" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" Your team Hedepy Tel.:+30 694 244 8711" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" Hedepy s.r.o., IČO: 09206281 V Tišině 474/3, Dejvice, 160 00 Praha 6"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")