# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"EMAIL:\s*([a-zA-Z0-9_.±]+@[a-zA-Z0-9-]+.[a-zA-Z0-9-.]+)\s*Τηλέφωνο:\s*(?<phone>\+?[\d\s-]+?)\s*Είστε πιστοποιημένος θεραπευτής;(?<therapist>[^\n]+)\s*Συμμετέχετε σε θεραπευτική εκπαίδευση;:(?<psychotherapy>[^\n]+)\s*"
test_str = ("Contact form - therapistForm \n"
" Below are the values the user has filled in the form. Beware they are not verified in any way and anyone could have sent the form as it is public. \n"
" \n"
" \n"
"EMAIL: katerina@hedepy.gr\n"
" \n"
" \n"
"Τηλέφωνο: 123456789\n"
" \n"
" \n"
"Είστε πιστοποιημένος θεραπευτής;: ναι\n"
" \n"
" \n"
"Συμμετέχετε σε θεραπευτική εκπαίδευση;: ναι\n"
" \n"
" \n"
" \n"
" \n"
" \n\n\n"
" Your team Hedepy Tel.:+30 694 244 8711\n"
" \n"
" \n\n\n"
" \n"
" Hedepy s.r.o., IČO: 09206281 V Tišině 474/3, Dejvice, 160 00 Praha 6")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.